注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

mie

 
 
 

日志

 
 

CentOS安装pam_mysql报错:libc.so.6(GLIBC_2.0) is needed by ****  

2014-10-23 10:33:33|  分类: linux、FreeBSD等 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
CentOS安装pam_mysql报错:libc.so.6(GLIBC_2.0) is needed by ****

        类似的错误有十多行,看字面意思,是缺少依赖库。但是我已经通过yum install的方式安装了最新的glibc库,问题依旧。

        应该和windows的类似,该rpm安装包的库是通过低版本的glibc库编译链接的,当前系统缺失低版本的glibc库,所以报错。
        我不愿意安装低版本的glibc库,因为这可能会带来一些问题,还是中规中矩地进行。
        所以,有另外两个解决方法:
       1. 在开发机器上面编译并制作pam_mysql的rpm包,然后放到开放模拟机器上去安装。这种方法显然通用一些,但是不是很方便,还得制作rpm包。
       2. 在开放模拟机器上面安装编译环境,显然,这种做法不可取,但是我还是用了这种方法:
yum install -y gcc gcc-c++ gcc4-c++ pam-devel

真正的外网环境,还是应该使用1的方法,虽然略为繁琐。

By: zhanyonhu
  评论这张
 
阅读(3998)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2016